<!DOCTYPE html>
    <!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"><![endif]-->
    <!--[if IE 7]><html class="no-js lt-ie9 lt-ie8" lang="en-US"><![endif]-->
    <!--[if IE 8]><html class="no-js lt-ie9" lang="en-US"><![endif]-->
    <!--[if gt IE 8]><!--><html class="no-js" lang="en-US"><!--<![endif]-->
<head><meta charset="UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="description" content="A local Davis band returns to Central Park with new energy



During Spring Quarter, students and Davis residents attend the Wednesday Farmer’" /><meta name="viewport" content="width=device-width, initial-scale=1" /><title>Tha Dirt Feelin - The Aggie</title>

<!-- This site is optimized with the Yoast SEO plugin v11.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="A local Davis band returns to Central Park with new energy During Spring Quarter, students and Davis residents attend the Wednesday Farmer’s Market to A local Davis band returns to Central Park with new energy"/>
<link rel="canonical" href="https://theaggie.org/2019/05/30/tha-dirt-feelin/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Tha Dirt Feelin - The Aggie" />
<meta property="og:description" content="A local Davis band returns to Central Park with new energy During Spring Quarter, students and Davis residents attend the Wednesday Farmer’s Market to A local Davis band returns to Central Park with new energy" />
<meta property="og:url" content="https://theaggie.org/2019/05/30/tha-dirt-feelin/" />
<meta property="og:site_name" content="The Aggie" />
<meta property="article:section" content="Arts &amp; Culture" />
<meta property="article:published_time" content="2019-05-30T23:35:15+00:00" />
<meta property="article:modified_time" content="2019-05-30T23:35:17+00:00" />
<meta property="og:updated_time" content="2019-05-30T23:35:17+00:00" />
<meta property="og:image" content="https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE.jpg" />
<meta property="og:image:secure_url" content="https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE.jpg" />
<meta property="og:image:width" content="695" />
<meta property="og:image:height" content="464" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="A local Davis band returns to Central Park with new energy During Spring Quarter, students and Davis residents attend the Wednesday Farmer’s Market to A local Davis band returns to Central Park with new energy" />
<meta name="twitter:title" content="Tha Dirt Feelin - The Aggie" />
<meta name="twitter:image" content="https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://theaggie.org/#organization","name":"The Aggie","url":"https://theaggie.org/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://theaggie.org/#logo","url":"https://theaggie.org/wp-content/uploads/2016/02/Unknown1.jpg","width":2967,"height":270,"caption":"The Aggie"},"image":{"@id":"https://theaggie.org/#logo"}},{"@type":"WebSite","@id":"https://theaggie.org/#website","url":"https://theaggie.org/","name":"The Aggie","publisher":{"@id":"https://theaggie.org/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://theaggie.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#webpage","url":"https://theaggie.org/2019/05/30/tha-dirt-feelin/","inLanguage":"en-US","name":"Tha Dirt Feelin - The Aggie","isPartOf":{"@id":"https://theaggie.org/#website"},"image":{"@type":"ImageObject","@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#primaryimage","url":"https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE.jpg","width":695,"height":464},"primaryImageOfPage":{"@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#primaryimage"},"datePublished":"2019-05-30T23:35:15+00:00","dateModified":"2019-05-30T23:35:17+00:00","description":"A local Davis band returns to Central Park with new energy During Spring Quarter, students and Davis residents attend the Wednesday Farmer\u2019s Market to A local Davis band returns to Central Park with new energy"},{"@type":"Article","@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#article","isPartOf":{"@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#webpage"},"author":{"@id":"https://theaggie.org/author/theaggie/#author"},"headline":"Tha Dirt Feelin","datePublished":"2019-05-30T23:35:15+00:00","dateModified":"2019-05-30T23:35:17+00:00","commentCount":0,"mainEntityOfPage":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#webpage","publisher":{"@id":"https://theaggie.org/#organization"},"image":{"@id":"https://theaggie.org/2019/05/30/tha-dirt-feelin/#primaryimage"},"articleSection":"Arts &amp; Culture"},{"@type":["Person"],"@id":"https://theaggie.org/author/theaggie/#author","name":"theaggie","image":{"@type":"ImageObject","@id":"https://theaggie.org/#authorlogo","url":"https://secure.gravatar.com/avatar/e1a249070626d0e95ba9784b1fc38843?s=96&d=mm&r=g","caption":"theaggie"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Aggie &raquo; Feed" href="https://theaggie.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Aggie &raquo; Comments Feed" href="https://theaggie.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Aggie &raquo; Tha Dirt Feelin Comments Feed" href="https://theaggie.org/2019/05/30/tha-dirt-feelin/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.6.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.6.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-22571355-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-22571355-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/theaggie.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=6ae6196510fd9cd4974b742acb52f190"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://theaggie.org/wp-includes/css/dist/block-library/style.min.css?ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<link rel='stylesheet' id='aggieads-style-css'  href='https://theaggie.org/wp-content/plugins/aggieads/css/aggieads-style.css?ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<link rel='stylesheet' id='radium_html5_media_styles-css'  href='https://theaggie.org/wp-content/plugins/radium-html5-media/assets/css/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='theme-google-fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%2C700%7CLato%3A100%2C300%2C400%2C700%2C900%2C100italic%2C300italic%2C400italic%2C700italic%2C900italic&#038;ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<link rel='stylesheet' id='framework-style-css'  href='https://theaggie.org/wp-content/themes/newscore/assets/css/style.min.css?ver=1.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='theme-print-css'  href='https://theaggie.org/wp-content/themes/newscore/assets/css/print.min.css?ver=1.9.4' type='text/css' media='print' />
<link rel='stylesheet' id='theme-mobile-css'  href='https://theaggie.org/wp-content/themes/newscore/assets/css/mobile.min.css?ver=1.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='radium-white-css'  href='https://theaggie.org/wp-content/themes/newscore/assets/css/skins/white.min.css?ver=1.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='gallery_plus-css'  href='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/galleria/themes/classic/galleria.classic.css?ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css'  href='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/css/jquery.fancybox.css?ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<link rel='stylesheet' id='fancyboxthumbs-css'  href='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/css/jquery.fancybox-thumbs.css?ver=6ae6196510fd9cd4974b742acb52f190' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/theaggie.org","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var radium_script = {"post_id":"58654","ajaxurl":"https:\/\/theaggie.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/aggieads/js/aggieads-js.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/themes/newscore/assets/js/modernizr.min.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/js/jquery.fancybox.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/js/jquery.fancybox-thumbs.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<link rel='https://api.w.org/' href='https://theaggie.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theaggie.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://theaggie.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://theaggie.org/?p=58654' />
<link rel="alternate" type="application/json+oembed" href="https://theaggie.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://theaggie.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//theaggie.org/?wordfence_lh=1&hid=A2C815465DE1255549728A6ADCE49E4E');
</script>    <script type="text/javascript">window.paceOptions = { elements: { selectors: ['#header' ] } }</script>
    <script src="https://theaggie.org/wp-content/themes/newscore/assets/js/pace.min.js"></script><link rel="shortcut icon" href="https://theaggie.org/wp-content/uploads/2015/02/Untitled1.png" type="image/x-icon" />
<link rel="apple-touch-icon" href="https://theaggie.org/wp-content/themes/newscore/assets/images/apple-touch-icon.png"/>
<script></script><script type="text/javascript" src="https://theaggie.org/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1559287049"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
<style>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</style>
<style></style><style>html, body {}h1, h2, h3, h4, h5, h6, .main_menu>ul>li>a, .main_menu>ul>li>a strong, #bottom-footer #footer-menu ul li a, .nav-tabs>li a, #colophon #theme-credits, .top-news .number, #main-menu .menu-item-object-category .sub-mega-wrap>ul>li .subcat-title, .widget_radium_post_tabs .tab-hold #tabs>li, .breadcrumb, .widget_radium_social_fans, #header .site-navigation .search-form .container input[type=text], #main-menu .menu-item-object-category.has-cat-megamenu .sub-mega-wrap>ul .subcat-title, .site-header-toolbar .menu.right>li>a, .site-header-toolbar .top-menu>li>a, #main-menu .menu-item-object-category.has-cat-megamenu .sub-mega-wrap:not(.single-cat) .sub-menu>li>a, .main_menu>ul>li>a, .main_menu>ul>li>a .menu-title-outer, .single .post-side-share .title, .video-central-nav-tabs>li, .site-header-toolbar .bag-header, #header .site-id, #header .site-id a, .fallback_menu .radium_mega>li>a, .buddypress div.item-list-tabs ul li a, .buddypress div.item-list-tabs ul li span, .buddypress div.item-list-tabs ul li a, .buddypress div.item-list-tabs ul li span, .buddypress div.poster-meta, .buddypress .item-list .activity-content .activity-header, .buddypress .item-list .activity-content .comment-header, .widget .swa-activity-list .swa-activity-content .swa-activity-header, .widget .swa-activity-list .swa-activity-content .comment-header, .buddypress div.activity-comments div.acomment-meta, .widget div.swa-activity-comments div.acomment-meta, li.bbp-forum-info, li.bbp-topic-title, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form legend, form label {}</style>		<style type="text/css" id="wp-custom-css">
			/* For the "See more" button on mobile */
@media only screen and (max-width: 767px) {
	.main_menu li.dl-front {
		display: block;
		padding: 0;
	}
}

.main_menu li.dl-front {
	display: none;
}

.wp-block-image figcaption {
	text-align: left;
}		</style>
		</head>
<body class="post-template-default single single-post postid-58654 single-format-standard ie singular group-blog boxed skin-white header-style-default custom-bg right-sidebar with-sidebar hide-featured-area" itemscope="itemscope" itemtype="http://schema.org/WebPage">

    
    <div id="theme-wrapper">
    	<div id="theme-wrapper-inner">
	    <div id="handheld-menu-holder"></div><!-- hidden --><header id="header" class=" has-trending logo-center" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">

        
        
        <div class="row">

            <div class="large-12 columns">

                <div class="site-id mobile-four clearfix">

                    <div class="site-title-wrapper" itemprop="headline"><a href="https://theaggie.org/" title="The Aggie" rel="home">The Aggie</a></div>
                    
                </div><!-- END .site-id -->

                
                <div class="site-header-banner mobile-four clearfix">

                    <div class="site-title-wrapper-2" itemprop="headline"><h1 class="site-title-2"><a href="https://theaggie.org/" title="The Aggie" rel="home"><img src="//theaggie.org/wp-content/uploads/2014/12/Unknown1.jpg" class="logo" alt="logo" width="700" height="100"></a></h1></div>
                </div><!-- END .site-header-banner -->

                
            </div><!-- END .large-12 .columns -->

        </div><!-- END .row -->

        <div class="site-navigation mobile-four">

            <div class="row">

                <div class="large-12 columns">

                    
		<!-- Main Navigation -->
		<nav class="nav-primary" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation">
			<div id="main-menu" class="main_menu clearfix">
				<button class="menu-trigger show-on-small">Open Menu</button>
				<ul id="menu-top-menu" class="radium_mega menu dl-menu"><li id="menu-item-36184" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Home</span></span></a></li>
<li id="menu-item-13653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/campus/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">News</span></span></a><div class="sub-mega-wrap radium-mega-div">



<ul class="sub-menu">
	<li id="menu-item-28155" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/campus/" itemprop="name"><span class="menu-title">Campus</span></a></li>
	<li id="menu-item-13654" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/city/" itemprop="name"><span class="menu-title">City</span></a></li>
	<li id="menu-item-56646" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/briefing/" itemprop="name"><span class="menu-title">Briefing</span></a></li>
</ul>
<ul class='subcat sub-cat-list'><li id='cat-latest-28155' class='active cat-latest-28155'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-28155' data-child_object_id='26'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/band-uh-placed-on-interim-suspension/' title='Band-Uh! placed on interim suspension'><img src="https://theaggie.org/wp-content/uploads/2019/05/battleofthebands_JUSTIN_HAN-7-e1559169479921-250x140.jpg" alt="Band-Uh! placed on interim suspension" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/band-uh-placed-on-interim-suspension/' title='Band-Uh! placed on interim suspension'>Band-Uh! placed on interim suspension</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/new-study-shows-significant-increase-in-cost-of-california-universities/' title='New study shows significant increase in cost of California universities'><img src="https://theaggie.org/wp-content/uploads/2019/05/publicunivcost_ca_JAMIECHEN_AGGIE-01-250x140.jpg" alt="New study shows significant increase in cost of California universities" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/new-study-shows-significant-increase-in-cost-of-california-universities/' title='New study shows significant increase in cost of California universities'>New study shows significant increase in cost of California universities</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/university-welcomes-three-new-administrators-to-campus/' title='University welcomes three new administrators to campus'><img src="https://theaggie.org/wp-content/uploads/2019/05/newadmin_ca-250x140.jpg" alt="University welcomes three new administrators to campus" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/university-welcomes-three-new-administrators-to-campus/' title='University welcomes three new administrators to campus'>University welcomes three new administrators to campus</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/taps-to-increase-parking-permit-rates-starting-july-1/' title='TAPS to increase parking permit rates starting July 1'><img src="https://theaggie.org/wp-content/uploads/2019/05/parkingprice_ca_QUINN_SPOONER_AGGIE-250x140.jpg" alt="TAPS to increase parking permit rates starting July 1" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/taps-to-increase-parking-permit-rates-starting-july-1/' title='TAPS to increase parking permit rates starting July 1'>TAPS to increase parking permit rates starting July 1</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/anti-zionism-week-held-at-uc-davis-student-leaders-organize-in-response/' title='Anti-Zionism week held at UC Davis, Aggies for Israel organizes response'><img src="https://theaggie.org/wp-content/uploads/2019/05/antizionism_ca_ZOË_REINHARDT-AGGIE-250x140.jpg" alt="Anti-Zionism week held at UC Davis, Aggies for Israel organizes response" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/anti-zionism-week-held-at-uc-davis-student-leaders-organize-in-response/' title='Anti-Zionism week held at UC Davis, Aggies for Israel organizes response'>Anti-Zionism week held at UC Davis, Aggies for Israel organizes response</a></h4></li></ul></li><!-- #cat-latest-28155 -->
<li id='cat-latest-13654' class=' cat-latest-13654'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-13654' data-child_object_id='25'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/flash-fire-on-campus-leaves-one-with-minor-injuries/' title='Flash fire on campus leaves one with minor injuries'><img src="https://theaggie.org/wp-content/uploads/2018/11/breakingnews_w18_SHEREEN-LEE_AGGIE-250x140.jpg" alt="Flash fire on campus leaves one with minor injuries" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/flash-fire-on-campus-leaves-one-with-minor-injuries/' title='Flash fire on campus leaves one with minor injuries'>Flash fire on campus leaves one with minor injuries</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/city-recruits-for-advisory-commissions/' title='City recruits for advisory commissions'><img src="https://theaggie.org/wp-content/uploads/2019/05/advisorycommissions_ci_JEREMY-DANGER_AGGIE-250x140.png" alt="City recruits for advisory commissions" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/city-recruits-for-advisory-commissions/' title='City recruits for advisory commissions'>City recruits for advisory commissions</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/police-logs-81/' title='Police Logs'><img src="https://theaggie.org/wp-content/uploads/2018/04/online_new-police-log_SHEREEN-LEE_AGGIE-250x140.jpg" alt="Police Logs" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/police-logs-81/' title='Police Logs'>Police Logs</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/first-davis-girl-scout-troop-to-join-boy-scouts/' title='First Davis Girl Scout troop to join Boy Scouts'><img src="https://theaggie.org/wp-content/uploads/2019/05/boygirlscouts_ci_ALLYSON-KO_AGGIE1-250x140.jpg" alt="First Davis Girl Scout troop to join Boy Scouts" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/first-davis-girl-scout-troop-to-join-boy-scouts/' title='First Davis Girl Scout troop to join Boy Scouts'>First Davis Girl Scout troop to join Boy Scouts</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/50th-annual-davis-double-century-took-place-in-lake-napa-yolo-counties/' title='50th annual Davis Double Century took place in Lake, Napa, Yolo counties'><img src="https://theaggie.org/wp-content/uploads/2019/05/cyclingtour_ci_MARKUS_KAEPPELI_AGGIE-e1558411386574-250x140.jpg" alt="50th annual Davis Double Century took place in Lake, Napa, Yolo counties" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/50th-annual-davis-double-century-took-place-in-lake-napa-yolo-counties/' title='50th annual Davis Double Century took place in Lake, Napa, Yolo counties'>50th annual Davis Double Century took place in Lake, Napa, Yolo counties</a></h4></li></ul></li><!-- #cat-latest-13654 -->
<li id='cat-latest-56646' class=' cat-latest-56646'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-56646' data-child_object_id='411'><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/drugging-incidents-at-davis-bars-investigation-of-ucd-polices-use-of-force-llamas-on-the-quad/' title='Drugging incidents at Davis bars, Investigation of UCD Police’s use of force, Llamas on the Quad'><img src="https://theaggie.org/wp-content/uploads/2019/03/newsletter_briefing_banner-640x92.png" alt="Drugging incidents at Davis bars, Investigation of UCD Police’s use of force, Llamas on the Quad" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/drugging-incidents-at-davis-bars-investigation-of-ucd-polices-use-of-force-llamas-on-the-quad/' title='Drugging incidents at Davis bars, Investigation of UCD Police’s use of force, Llamas on the Quad'>Drugging incidents at Davis bars, Investigation of UCD Police’s use of force, Llamas on the Quad</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/17/best-of-davis-2019-5th-annual-davis-pride-a-closer-look-into-asian-greek-life-your-weekly-briefing/' title='Best of Davis 2019, 5th Annual Davis Pride, A closer look into Asian Greek Life: Your Weekly Briefing'><img src="https://theaggie.org/wp-content/uploads/2019/03/newsletter_briefing_banner-1-640x92.png" alt="Best of Davis 2019, 5th Annual Davis Pride, A closer look into Asian Greek Life: Your Weekly Briefing" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/17/best-of-davis-2019-5th-annual-davis-pride-a-closer-look-into-asian-greek-life-your-weekly-briefing/' title='Best of Davis 2019, 5th Annual Davis Pride, A closer look into Asian Greek Life: Your Weekly Briefing'>Best of Davis 2019, 5th Annual Davis Pride, A closer look into Asian Greek Life: Your Weekly Briefing</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/10/free-menstrual-products-for-students-whole-earth-festival-and-celebrate-davis-your-weekly-briefing/' title='Free menstrual products for students, Whole Earth Festival, and Celebrate Davis: Your Weekly Briefing'><img src="https://theaggie.org/wp-content/uploads/2019/03/newsletter_briefing_banner-640x92.png" alt="Free menstrual products for students, Whole Earth Festival, and Celebrate Davis: Your Weekly Briefing" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/10/free-menstrual-products-for-students-whole-earth-festival-and-celebrate-davis-your-weekly-briefing/' title='Free menstrual products for students, Whole Earth Festival, and Celebrate Davis: Your Weekly Briefing'>Free menstrual products for students, Whole Earth Festival, and Celebrate Davis: Your Weekly Briefing</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/03/uc-davis-ranked-second-on-top-colleges-advocating-for-mental-health-awareness-theta-xi-to-demolish-2-houses-kdvs-celebrates-50-years-your-weekly-briefing/' title='UC Davis ranked second on, ‘Top Colleges Advocating for Mental Health Awareness’,  Theta Xi to demolish 2 houses, KDVS Celebrates 50 years: Your Weekly Briefing'><img src="https://theaggie.org/wp-content/uploads/2019/03/newsletter_briefing_banner-1-640x92.png" alt="UC Davis ranked second on, ‘Top Colleges Advocating for Mental Health Awareness’,  Theta Xi to demolish 2 houses, KDVS Celebrates 50 years: Your Weekly Briefing" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/03/uc-davis-ranked-second-on-top-colleges-advocating-for-mental-health-awareness-theta-xi-to-demolish-2-houses-kdvs-celebrates-50-years-your-weekly-briefing/' title='UC Davis ranked second on, ‘Top Colleges Advocating for Mental Health Awareness’,  Theta Xi to demolish 2 houses, KDVS Celebrates 50 years: Your Weekly Briefing'>UC Davis ranked second on, ‘Top Colleges Advocating for Mental Health Awareness’,  Theta Xi to demolish 2 houses, KDVS Celebrates 50 years: Your Weekly Briefing</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/04/26/student-housing-projects-halted-aggie-wide-receiver-hopeful-nfl-draft-2-uc-davis-professors-win-guggenheim-fellowship-your-weekly-briefing/' title='Student housing projects halted, Aggie wide receiver hopeful NFL draft, 2 UC Davis professors win Guggenheim Fellowship: Your Weekly Briefing'><img src="https://theaggie.org/wp-content/uploads/2019/03/newsletter_briefing_banner-1-640x92.png" alt="Student housing projects halted, Aggie wide receiver hopeful NFL draft, 2 UC Davis professors win Guggenheim Fellowship: Your Weekly Briefing" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/04/26/student-housing-projects-halted-aggie-wide-receiver-hopeful-nfl-draft-2-uc-davis-professors-win-guggenheim-fellowship-your-weekly-briefing/' title='Student housing projects halted, Aggie wide receiver hopeful NFL draft, 2 UC Davis professors win Guggenheim Fellowship: Your Weekly Briefing'>Student housing projects halted, Aggie wide receiver hopeful NFL draft, 2 UC Davis professors win Guggenheim Fellowship: Your Weekly Briefing</a></h4></li></ul></li><!-- #cat-latest-56646 -->
</ul><!-- .subcat -->
</div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-13655" class="menu-item menu-item-type-taxonomy menu-item-object-category has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/features/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Features</span></span></a><div class="sub-mega-wrap radium-mega-div cat-menu single-cat"><ul class="sub-posts subcat sub-menu large-block-grid-5"><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/small-farming-finds-its-niche/' title='Small farming finds its niche'><img src="https://theaggie.org/wp-content/uploads/2019/05/farmcorp_fe_JEREMY-DANGER_AGGIE-250x140.png" alt="Small farming finds its niche" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/small-farming-finds-its-niche/' title='Small farming finds its niche'>Small farming finds its niche</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/outstanding-student-awards/' title='Outstanding Student Awards'><img src="https://theaggie.org/wp-content/uploads/2019/05/outstandingseniors_fe_OLIVIA-KOTLAREK_AGGIE-01-250x140.png" alt="Outstanding Student Awards" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/outstanding-student-awards/' title='Outstanding Student Awards'>Outstanding Student Awards</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/research-using-new-robotic-technology-improves-agricultural-techniques/' title='Research using new robotic technology improves agricultural techniques'><img src="https://theaggie.org/wp-content/uploads/2019/05/DavidSlaughter_fe_STAVROS-VOUGIOUSKAS_COURTESY-250x140.jpg" alt="Research using new robotic technology improves agricultural techniques" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/research-using-new-robotic-technology-improves-agricultural-techniques/' title='Research using new robotic technology improves agricultural techniques'>Research using new robotic technology improves agricultural techniques</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/should-you-take-an-online-class-here-are-the-pros-and-cons/' title='Should you take an online class? Here are the pros and cons'><img src="https://theaggie.org/wp-content/uploads/2019/05/onlineclasses_fe_MOFFAT_DANIELLE_AGGIE-e1558412366695-250x140.jpg" alt="Should you take an online class? Here are the pros and cons" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/should-you-take-an-online-class-here-are-the-pros-and-cons/' title='Should you take an online class? Here are the pros and cons'>Should you take an online class? Here are the pros and cons</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/zero-waste-lifestyle-proves-impactful-difficult-to-achieve-for-students/' title='Zero waste lifestyle proves impactful, difficult to achieve for students'><img src="https://theaggie.org/wp-content/uploads/2019/05/zerowaste_fe_ALLYSON-KO_AGGIE-250x140.jpg" alt="Zero waste lifestyle proves impactful, difficult to achieve for students" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/zero-waste-lifestyle-proves-impactful-difficult-to-achieve-for-students/' title='Zero waste lifestyle proves impactful, difficult to achieve for students'>Zero waste lifestyle proves impactful, difficult to achieve for students</a></h4></li><li class="dl-front"><a href="https://theaggie.org/features/">See More</a></li></ul></div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-13657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/opinion/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Opinion</span></span></a><div class="sub-mega-wrap radium-mega-div">



<ul class="sub-menu">
	<li id="menu-item-46031" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/opinion/editorial/" itemprop="name"><span class="menu-title">Editorial</span></a></li>
	<li id="menu-item-46033" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/opinion/guest/" itemprop="name"><span class="menu-title">Guest</span></a></li>
	<li id="menu-item-46032" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/opinion/column/" itemprop="name"><span class="menu-title">Column</span></a></li>
	<li id="menu-item-46034" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/opinion/humor/" itemprop="name"><span class="menu-title">Humor</span></a></li>
</ul>
<ul class='subcat sub-cat-list'><li id='cat-latest-46031' class='active cat-latest-46031'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-46031' data-child_object_id='400'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/30/on-campus-parking-should-be-more-affordable-for-available-to-students/' title='On-campus parking should be more affordable for, available to students'><img src="https://theaggie.org/wp-content/uploads/2018/04/Editorial_CAITLYN-SAMPLEY_AGGIE-250x140.jpg" alt="On-campus parking should be more affordable for, available to students" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/30/on-campus-parking-should-be-more-affordable-for-available-to-students/' title='On-campus parking should be more affordable for, available to students'>On-campus parking should be more affordable for, available to students</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/billionaires-are-not-the-solution-to-overwhelming-student-debt/' title='Billionaires are not the solution to overwhelming student debt'><img src="https://theaggie.org/wp-content/uploads/2018/04/Editorial_CAITLYN-SAMPLEY_AGGIE-250x140.jpg" alt="Billionaires are not the solution to overwhelming student debt" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/billionaires-are-not-the-solution-to-overwhelming-student-debt/' title='Billionaires are not the solution to overwhelming student debt'>Billionaires are not the solution to overwhelming student debt</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/23/watch-your-drinks-in-wake-of-drugging-incidents-at-davis-bars/' title='Watch your drinks in wake of drugging incidents at Davis bars'><img src="https://theaggie.org/wp-content/uploads/2018/04/Editorial_CAITLYN-SAMPLEY_AGGIE-250x140.jpg" alt="Watch your drinks in wake of drugging incidents at Davis bars" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/23/watch-your-drinks-in-wake-of-drugging-incidents-at-davis-bars/' title='Watch your drinks in wake of drugging incidents at Davis bars'>Watch your drinks in wake of drugging incidents at Davis bars</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/16/sb-24-would-secure-access-to-abortion-pills-on-california-public-university-campuses/' title='SB 24 would secure access to abortion pills on California public university campuses'><img src="https://theaggie.org/wp-content/uploads/2018/04/Editorial_CAITLYN-SAMPLEY_AGGIE-250x140.jpg" alt="SB 24 would secure access to abortion pills on California public university campuses" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/16/sb-24-would-secure-access-to-abortion-pills-on-california-public-university-campuses/' title='SB 24 would secure access to abortion pills on California public university campuses'>SB 24 would secure access to abortion pills on California public university campuses</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/10/this-mothers-day-remember-the-holidays-radical-roots/' title='This Mother’s Day, remember the holiday’s radical roots'><img src="https://theaggie.org/wp-content/uploads/2018/04/Editorial_CAITLYN-SAMPLEY_AGGIE-250x140.jpg" alt="This Mother’s Day, remember the holiday’s radical roots" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/10/this-mothers-day-remember-the-holidays-radical-roots/' title='This Mother’s Day, remember the holiday’s radical roots'>This Mother’s Day, remember the holiday’s radical roots</a></h4></li></ul></li><!-- #cat-latest-46031 -->
<li id='cat-latest-46033' class=' cat-latest-46033'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-46033' data-child_object_id='398'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/guest-uc-davis-climbs-ladder-to-a-carbon-free-campus/' title='Guest: UC Davis climbs ladder to a carbon-free campus'><img src="https://theaggie.org/wp-content/uploads/2019/02/guest_opinion_CAITLYN-SAMPLEY_AGGIE-250x140.png" alt="Guest: UC Davis climbs ladder to a carbon-free campus" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/guest-uc-davis-climbs-ladder-to-a-carbon-free-campus/' title='Guest: UC Davis climbs ladder to a carbon-free campus'>Guest: UC Davis climbs ladder to a carbon-free campus</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/22/guest-uc-davis-inadequate-mental-health-resources/' title='Guest: UC Davis’ inadequate mental health resources'><img src="https://theaggie.org/wp-content/uploads/2019/02/guest_opinion_CAITLYN-SAMPLEY_AGGIE-250x140.png" alt="Guest: UC Davis’ inadequate mental health resources" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/22/guest-uc-davis-inadequate-mental-health-resources/' title='Guest: UC Davis’ inadequate mental health resources'>Guest: UC Davis’ inadequate mental health resources</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/13/guest-the-police-again/' title='Guest: The police, again'><img src="https://theaggie.org/wp-content/uploads/2019/02/guest_opinion_CAITLYN-SAMPLEY_AGGIE-250x140.png" alt="Guest: The police, again" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/13/guest-the-police-again/' title='Guest: The police, again'>Guest: The police, again</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/07/what-does-it-mean-to-be-a-white-supremacist/' title='Guest: What does it mean to be a white supremacist?'><img src="https://theaggie.org/wp-content/uploads/2019/02/guest_opinion_CAITLYN-SAMPLEY_AGGIE-250x140.png" alt="Guest: What does it mean to be a white supremacist?" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/07/what-does-it-mean-to-be-a-white-supremacist/' title='Guest: What does it mean to be a white supremacist?'>Guest: What does it mean to be a white supremacist?</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/03/guest-californias-chance-to-break-its-single-use-plastic-addiction/' title='Guest: California’s chance to break its single-use plastic addiction'><img src="https://theaggie.org/wp-content/uploads/2019/02/guest_opinion_CAITLYN-SAMPLEY_AGGIE-250x140.png" alt="Guest: California’s chance to break its single-use plastic addiction" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/03/guest-californias-chance-to-break-its-single-use-plastic-addiction/' title='Guest: California’s chance to break its single-use plastic addiction'>Guest: California’s chance to break its single-use plastic addiction</a></h4></li></ul></li><!-- #cat-latest-46033 -->
<li id='cat-latest-46032' class=' cat-latest-46032'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-46032' data-child_object_id='399'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/heaven-helps-those-who-help-themselves-for-25/' title='“Heaven helps those who help themselves” — for $25!'><img src="https://theaggie.org/wp-content/uploads/2019/05/selfhelp_op-250x140.jpg" alt="“Heaven helps those who help themselves” — for $25!" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/heaven-helps-those-who-help-themselves-for-25/' title='“Heaven helps those who help themselves” — for $25!'>“Heaven helps those who help themselves” — for $25!</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/recycling-is-hard-and-its-not-your-fault/' title='Recycling is hard and it’s not your fault'><img src="https://theaggie.org/wp-content/uploads/2019/05/davisrecycling_op_QUINN_SPOONER_AGGIE-250x140.jpg" alt="Recycling is hard and it’s not your fault" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/recycling-is-hard-and-its-not-your-fault/' title='Recycling is hard and it’s not your fault'>Recycling is hard and it’s not your fault</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/your-white-collar-job-is-not-safe-from-automation/' title='Your white-collar job is not safe from automation'><img src="https://theaggie.org/wp-content/uploads/2019/05/automation_op_KATHERINE_FRANKS_AGGIE-250x140.png" alt="Your white-collar job is not safe from automation" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/your-white-collar-job-is-not-safe-from-automation/' title='Your white-collar job is not safe from automation'>Your white-collar job is not safe from automation</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/the-importance-of-campfires/' title='The importance of campfires'><img src="https://theaggie.org/wp-content/uploads/2019/05/campfires_op_ALLYSON-KO_AGGIE-250x140.jpg" alt="The importance of campfires" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/the-importance-of-campfires/' title='The importance of campfires'>The importance of campfires</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/bigger-better-faster-games-are-getting-harder-to-put-down/' title='Bigger, Better, Faster: Games are getting harder to put down'><img src="https://theaggie.org/wp-content/uploads/2019/05/gameaddiction_op-e1558413895724-250x140.jpg" alt="Bigger, Better, Faster: Games are getting harder to put down" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/bigger-better-faster-games-are-getting-harder-to-put-down/' title='Bigger, Better, Faster: Games are getting harder to put down'>Bigger, Better, Faster: Games are getting harder to put down</a></h4></li></ul></li><!-- #cat-latest-46032 -->
<li id='cat-latest-46034' class=' cat-latest-46034'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-46034' data-child_object_id='397'><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/humor-tercero-to-convert-into-japanese-style-capsule-hotel-for-maximum-profits/' title='Humor: Tercero to convert into Japanese-style capsule hotel for maximum profits'><img src="https://theaggie.org/wp-content/uploads/2019/05/podhotel_op_TESSA_KOGA_AGGIE-250x140.jpg" alt="Humor: Tercero to convert into Japanese-style capsule hotel for maximum profits" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/humor-tercero-to-convert-into-japanese-style-capsule-hotel-for-maximum-profits/' title='Humor: Tercero to convert into Japanese-style capsule hotel for maximum profits'>Humor: Tercero to convert into Japanese-style capsule hotel for maximum profits</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/humor-pitch-for-working-title-a-disaster-movie-on-the-hypothetical-threat-of-climate-change/' title='Humor: Pitch for WORKING TITLE, a disaster movie on the hypothetical threat of “climate change”'><img src="https://theaggie.org/wp-content/uploads/2019/05/Climatepitch_op_CAITLYN_SAMPLEY_AGGIE-250x140.jpg" alt="Humor: Pitch for WORKING TITLE, a disaster movie on the hypothetical threat of “climate change”" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/humor-pitch-for-working-title-a-disaster-movie-on-the-hypothetical-threat-of-climate-change/' title='Humor: Pitch for WORKING TITLE, a disaster movie on the hypothetical threat of “climate change”'>Humor: Pitch for WORKING TITLE, a disaster movie on the hypothetical threat of “climate change”</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/cartoon-canvas/' title='Cartoon: Canvas'><img src="https://theaggie.org/wp-content/uploads/2019/05/image2-2.png" alt="Cartoon: Canvas" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/cartoon-canvas/' title='Cartoon: Canvas'>Cartoon: Canvas</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/22/humor-dc-hosts-houseboats-themed-meal-with-only-dino-chicken-nuggets-alcohol/' title='Humor: DC hosts houseboats-themed meal with only dino chicken nuggets, alcohol'><img src="https://theaggie.org/wp-content/uploads/2019/05/houseboats_op_TESSA_KOGA_AGGIE-250x140.png" alt="Humor: DC hosts houseboats-themed meal with only dino chicken nuggets, alcohol" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/22/humor-dc-hosts-houseboats-themed-meal-with-only-dino-chicken-nuggets-alcohol/' title='Humor: DC hosts houseboats-themed meal with only dino chicken nuggets, alcohol'>Humor: DC hosts houseboats-themed meal with only dino chicken nuggets, alcohol</a></h4></li><li class='has-thumbnail clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/19/humor-an-investigation-into-the-vast-and-extremely-successful-conspiracy-to-cover-up-amish-cybercrime/' title='Humor: An investigation into the vast and extremely successful conspiracy to cover-up Amish cybercrime'><img src="https://theaggie.org/wp-content/uploads/2019/05/amish_op_MELINDACHEN-250x140.png" alt="Humor: An investigation into the vast and extremely successful conspiracy to cover-up Amish cybercrime" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/19/humor-an-investigation-into-the-vast-and-extremely-successful-conspiracy-to-cover-up-amish-cybercrime/' title='Humor: An investigation into the vast and extremely successful conspiracy to cover-up Amish cybercrime'>Humor: An investigation into the vast and extremely successful conspiracy to cover-up Amish cybercrime</a></h4></li></ul></li><!-- #cat-latest-46034 -->
</ul><!-- .subcat -->
</div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-42760" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/arts/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Arts and Culture</span></span></a><div class="sub-mega-wrap radium-mega-div cat-menu single-cat"><ul class="sub-posts subcat sub-menu large-block-grid-5"><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/30/tha-dirt-feelin/' title='Tha Dirt Feelin'><img src="https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE-250x140.jpg" alt="Tha Dirt Feelin" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/30/tha-dirt-feelin/' title='Tha Dirt Feelin'>Tha Dirt Feelin</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/cooking-with-wine/' title='Cooking with Wine'><img src="https://theaggie.org/wp-content/uploads/2019/05/LRG_DSC05289-e1558316445676-250x140.jpg" alt="Cooking with Wine" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/cooking-with-wine/' title='Cooking with Wine'>Cooking with Wine</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/cclass-hosts-patio-de-colores/' title='CCLASS hosts Patio De Colores'><img src="https://theaggie.org/wp-content/uploads/2019/05/patio_ar_ROXANDA-REYES_COURTESY-250x140.jpg" alt="CCLASS hosts Patio De Colores" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/cclass-hosts-patio-de-colores/' title='CCLASS hosts Patio De Colores'>CCLASS hosts Patio De Colores</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/grand-opening-burger-patch/' title='Grand Opening: Burger Patch'><img src="https://theaggie.org/wp-content/uploads/2019/05/burgerpatch_ar_DANEA-HORN_COURTESY-250x140.jpeg" alt="Grand Opening: Burger Patch" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/grand-opening-burger-patch/' title='Grand Opening: Burger Patch'>Grand Opening: Burger Patch</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/commentary-the-childrens-books-that-define-us/' title='Commentary: The Children’s Books that Define Us'><img src="https://theaggie.org/wp-content/uploads/2019/05/childrensbooks_ar_ALLYSON-KO_AGGIE-250x140.jpg" alt="Commentary: The Children’s Books that Define Us" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/commentary-the-childrens-books-that-define-us/' title='Commentary: The Children’s Books that Define Us'>Commentary: The Children’s Books that Define Us</a></h4></li><li class="dl-front"><a href="https://theaggie.org/arts/">See More</a></li></ul></div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-13659" class="menu-item menu-item-type-taxonomy menu-item-object-category has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/sports/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Sports</span></span></a><div class="sub-mega-wrap radium-mega-div cat-menu single-cat"><ul class="sub-posts subcat sub-menu large-block-grid-5"><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/29/the-sports-world-continues-to-be-plagued-by-the-drake-curse/' title='The sports world continues to be plagued by ‘The Drake Curse’'><img src="https://theaggie.org/wp-content/uploads/2019/05/drakecurse_sp_JEREMY-DANGER_AGGIE-250x140.png" alt="The sports world continues to be plagued by ‘The Drake Curse’" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/29/the-sports-world-continues-to-be-plagued-by-the-drake-curse/' title='The sports world continues to be plagued by ‘The Drake Curse’'>The sports world continues to be plagued by ‘The Drake Curse’</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/ranking-the-best-months-of-the-year-for-sports-fans/' title='Ranking the best months of the year for sports fans'><img src="https://theaggie.org/wp-content/uploads/2019/05/sportsmonths_sp_OLIVIA-KOTLAREK_AGGIE-01-250x140.png" alt="Ranking the best months of the year for sports fans" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/ranking-the-best-months-of-the-year-for-sports-fans/' title='Ranking the best months of the year for sports fans'>Ranking the best months of the year for sports fans</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/28/the-state-of-officiating-where-does-justice-become-entitlement/' title='The State of Officiating: Where does justice become entitlement?'><img src="https://theaggie.org/wp-content/uploads/2019/05/refereeing_sp_KATHERINE_FRANKS_AGGIE-250x140.png" alt="The State of Officiating: Where does justice become entitlement?" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/28/the-state-of-officiating-where-does-justice-become-entitlement/' title='The State of Officiating: Where does justice become entitlement?'>The State of Officiating: Where does justice become entitlement?</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/uc-davis-club-lacrosse-season-recap/' title='UC Davis club lacrosse season recap'><img src="https://theaggie.org/wp-content/uploads/2019/05/clublax_sp_UC-DAVIS-MENS-CLUB-LACROSSE_COURTESY-250x140.jpg" alt="UC Davis club lacrosse season recap" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/uc-davis-club-lacrosse-season-recap/' title='UC Davis club lacrosse season recap'>UC Davis club lacrosse season recap</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/what-the-recent-increase-in-horse-deaths-means-for-the-future-of-horse-racing/' title='What the recent increase in horse deaths means for the future of horse racing'><img src="https://theaggie.org/wp-content/uploads/2019/05/horsederby_sp_MELINDACHEN-250x140.png" alt="What the recent increase in horse deaths means for the future of horse racing" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/what-the-recent-increase-in-horse-deaths-means-for-the-future-of-horse-racing/' title='What the recent increase in horse deaths means for the future of horse racing'>What the recent increase in horse deaths means for the future of horse racing</a></h4></li><li class="dl-front"><a href="https://theaggie.org/sports/">See More</a></li></ul></div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-43537" class="menu-item menu-item-type-taxonomy menu-item-object-category has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/sciencetech/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Science</span></span></a><div class="sub-mega-wrap radium-mega-div cat-menu single-cat"><ul class="sub-posts subcat sub-menu large-block-grid-5"><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/27/is-a-heat-wave-coming-to-davis-did-it-rain-in-the-east-indian-ocean/' title='Is a heat wave coming to Davis? Did it rain in the East Indian Ocean?'><img src="https://theaggie.org/wp-content/uploads/2019/05/heatwave_sc-250x140.jpg" alt="Is a heat wave coming to Davis? Did it rain in the East Indian Ocean?" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/27/is-a-heat-wave-coming-to-davis-did-it-rain-in-the-east-indian-ocean/' title='Is a heat wave coming to Davis? Did it rain in the East Indian Ocean?'>Is a heat wave coming to Davis? Did it rain in the East Indian Ocean?</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/nibbling-away-at-discovery/' title='Nibbling away at discovery'><img src="https://theaggie.org/wp-content/uploads/2019/05/amoeba_sc_DAVID-SLIPHER_COURTESY-250x140.jpeg" alt="Nibbling away at discovery" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/nibbling-away-at-discovery/' title='Nibbling away at discovery'>Nibbling away at discovery</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/24/measles-is-going-viral/' title='Measles is going viral'><img src="https://theaggie.org/wp-content/uploads/2019/05/vaccination-2722937_1920-e1558315542853-250x140.jpg" alt="Measles is going viral" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/24/measles-is-going-viral/' title='Measles is going viral'>Measles is going viral</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/13/paul-hastings/' title='Paul Hastings'><img src="https://theaggie.org/wp-content/uploads/2019/05/hastings_sc-250x140.jpg" alt="Paul Hastings" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/13/paul-hastings/' title='Paul Hastings'>Paul Hastings</a></h4></li><li class="cat-post has-thumbnail clearfix"><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/05/13/raissa-dsouza/' title='Raissa D’Souza'><img src="https://theaggie.org/wp-content/uploads/2019/05/dsouza_sc_ALEXA_FONTANILLA_AGGIE-e1557160674582-250x140.jpg" alt="Raissa D’Souza" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/05/13/raissa-dsouza/' title='Raissa D’Souza'>Raissa D’Souza</a></h4></li><li class="dl-front"><a href="https://theaggie.org/sciencetech/">See More</a></li></ul></div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-41173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-parent-item has-cat-megamenu color-none" itemprop="name"><a href="https://theaggie.org/photo/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Photo</span></span></a><div class="sub-mega-wrap radium-mega-div">



<ul class="sub-menu">
	<li id="menu-item-41175" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/photo/photo-of-the-week/" itemprop="name"><span class="menu-title">Photo of the Week</span></a></li>
	<li id="menu-item-41174" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/photo/focus/" itemprop="name"><span class="menu-title">Focus</span></a></li>
</ul>
<ul class='subcat sub-cat-list'><li id='cat-latest-41175' class='active cat-latest-41175'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-41175' data-child_object_id='379'><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/05/24/photo-of-the-week-5242017/' title='Photo of the Week: 5/24/2017'><img src="https://theaggie.org/wp-content/uploads/2017/05/PotW_Chan_2.jpg" alt="Photo of the Week: 5/24/2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/05/24/photo-of-the-week-5242017/' title='Photo of the Week: 5/24/2017'>Photo of the Week: 5/24/2017</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/05/17/photo-of-the-week-5172017/' title='Photo of the Week: 5/17/2017'><img src="https://theaggie.org/wp-content/uploads/2017/05/PotW_Chan_3.jpg" alt="Photo of the Week: 5/17/2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/05/17/photo-of-the-week-5172017/' title='Photo of the Week: 5/17/2017'>Photo of the Week: 5/17/2017</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/05/10/photo-of-the-week-5112017/' title='Photo of the Week: 5/11/2017'><img src="https://theaggie.org/wp-content/uploads/2017/05/PotW_Nicole_Washington.jpg" alt="Photo of the Week: 5/11/2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/05/10/photo-of-the-week-5112017/' title='Photo of the Week: 5/11/2017'>Photo of the Week: 5/11/2017</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/05/03/photo-of-the-week-532017/' title='Photo of the Week: 5/3/2017'><img src="https://theaggie.org/wp-content/uploads/2017/05/PotW_Diana_Li.jpg" alt="Photo of the Week: 5/3/2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/05/03/photo-of-the-week-532017/' title='Photo of the Week: 5/3/2017'>Photo of the Week: 5/3/2017</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/04/19/photo-of-the-week-4192017/' title='Photo of the Week: 4/19/2017'><img src="https://theaggie.org/wp-content/uploads/2017/04/PotW_Kelsey_Gregge.jpg" alt="Photo of the Week: 4/19/2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/04/19/photo-of-the-week-4192017/' title='Photo of the Week: 4/19/2017'>Photo of the Week: 4/19/2017</a></h4></li></ul></li><!-- #cat-latest-41175 -->
<li id='cat-latest-41174' class=' cat-latest-41174'><ul class='large-block-grid-5  cat-tab-content cat-tab-content-41174' data-child_object_id='380'><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/04/19/through-the-lens-of-the-105th-picnic-day/' title='Through the Lens of the 105th Picnic Day'><img src="https://theaggie.org/wp-content/uploads/2019/04/image1.jpg" alt="Through the Lens of the 105th Picnic Day" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/04/19/through-the-lens-of-the-105th-picnic-day/' title='Through the Lens of the 105th Picnic Day'>Through the Lens of the 105th Picnic Day</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2019/01/31/meaningful-memories/' title='Meaningful Memories'><img src="https://theaggie.org/wp-content/uploads/2019/01/meaningful_ph_JUSTIN_HAN-640x360.jpg" alt="Meaningful Memories" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2019/01/31/meaningful-memories/' title='Meaningful Memories'>Meaningful Memories</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2018/05/01/picnic-day-2018-in-photos/' title='Picnic Day 2018 in Photos'><img src="https://theaggie.org/wp-content/uploads/2018/05/BattleoftheBands_Taylor_LaPoint1-e1525196467700.jpg" alt="Picnic Day 2018 in Photos" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2018/05/01/picnic-day-2018-in-photos/' title='Picnic Day 2018 in Photos'>Picnic Day 2018 in Photos</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2018/03/30/in-photos-march-for-our-lives-sacramento/' title='In Photos: March for Our Lives Sacramento'><img src="https://theaggie.org/wp-content/uploads/2018/03/Copy-of-March-for-Our-Lives-68-e1522429088573.jpg" alt="In Photos: March for Our Lives Sacramento" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2018/03/30/in-photos-march-for-our-lives-sacramento/' title='In Photos: March for Our Lives Sacramento'>In Photos: March for Our Lives Sacramento</a></h4></li><li class='no-thumb clearfix'><div class='subcat-thumbnail entry-content-media'><div class='post-thumb zoom-img-in'><a href='https://theaggie.org/2017/12/28/year-photos-2017/' title='The Year in Photos — 2017'><img src="https://theaggie.org/wp-content/uploads/2017/12/year_ph.jpg" alt="The Year in Photos — 2017" width="250" height="140"/></a></div><div class="entry-meta"></div><div class="entry-extras"></div></div><h4 class='subcat-title'><a href='https://theaggie.org/2017/12/28/year-photos-2017/' title='The Year in Photos — 2017'>The Year in Photos — 2017</a></h4></li></ul></li><!-- #cat-latest-41174 -->
</ul><!-- .subcat -->
</div><!-- .sub-mega-wrap -->
</li>
<li id="menu-item-49169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-parent-item has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/best-of-davis/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Best of Davis</span></span></a>


<ul class="sub-menu">
	<li id="menu-item-58375" class="menu-item menu-item-type-taxonomy menu-item-object-category color-none" itemprop="name"><a href="https://theaggie.org/best-of-davis-2016-features/best-of-davis-2019/" itemprop="name"><span class="menu-title">Best of Davis 2019</span></a></li>
	<li id="menu-item-53725" class="menu-item menu-item-type-post_type menu-item-object-page" itemprop="name"><a href="https://theaggie.org/best-of-davis/best-of-davis-2018/" itemprop="name"><span class="menu-title">Best of Davis 2018</span></a></li>
	<li id="menu-item-49165" class="menu-item menu-item-type-post_type menu-item-object-page" itemprop="name"><a href="https://theaggie.org/best-of-davis/best-of-davis-2017/" itemprop="name"><span class="menu-title">Best of Davis 2017</span></a></li>
</ul>
</li>
<li id="menu-item-39312" class="menu-item menu-item-type-post_type menu-item-object-page has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/contact/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Contact</span></span></a></li>
<li id="menu-item-46952" class="menu-item menu-item-type-post_type menu-item-object-page has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/advertising/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Advertising</span></span></a></li>
<li id="menu-item-48188" class="menu-item menu-item-type-post_type menu-item-object-page has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/print/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Print</span></span></a></li>
<li id="menu-item-38879" class="menu-item menu-item-type-post_type menu-item-object-page has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/search/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Search</span></span></a></li>
<li id="menu-item-50195" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-last has-one-col-dropdown" itemprop="name"><a href="https://theaggie.org/classifieds/" itemprop="name"><span class="menu-title-outer"><span class="menu-title">Classifieds</span></span></a></li>
</ul>			</div>
 		</nav>
		<!-- /End Main Menu -->

<div class="breaking-banner" data-interval="4000"><div class="story">	            <div class="meta-bar-title"><h3><a href="#">Breaking</a></h3></div><!-- .meta-bar-title -->
	            <div class="meta-bar">
	            	<ul>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/30/tha-dirt-feelin/">
	                       	    	<span class="story-title">Tha Dirt Feelin</span>
	                            	<span class="story-time">  - 8 hours ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/30/on-campus-parking-should-be-more-affordable-for-available-to-students/">
	                       	    	<span class="story-title">On-campus parking should be more affordable for, available to students</span>
	                            	<span class="story-time">  - 22 hours ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/band-uh-placed-on-interim-suspension/">
	                       	    	<span class="story-title">Band-Uh! placed on interim suspension</span>
	                            	<span class="story-time">  - 1 day ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/flash-fire-on-campus-leaves-one-with-minor-injuries/">
	                       	    	<span class="story-title">Flash fire on campus leaves one with minor injuries</span>
	                            	<span class="story-time">  - 1 day ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/cooking-with-wine/">
	                       	    	<span class="story-title">Cooking with Wine</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/guest-uc-davis-climbs-ladder-to-a-carbon-free-campus/">
	                       	    	<span class="story-title">Guest: UC Davis climbs ladder to a carbon-free campus</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/humor-tercero-to-convert-into-japanese-style-capsule-hotel-for-maximum-profits/">
	                       	    	<span class="story-title">Humor: Tercero to convert into Japanese-style capsule hotel for maximum profits</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/heaven-helps-those-who-help-themselves-for-25/">
	                       	    	<span class="story-title">“Heaven helps those who help themselves” — for $25!</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/new-study-shows-significant-increase-in-cost-of-california-universities/">
	                       	    	<span class="story-title">New study shows significant increase in cost of California universities</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                    <li>
							<h3 class="story-h">
								<a href="https://theaggie.org/2019/05/29/the-sports-world-continues-to-be-plagued-by-the-drake-curse/">
	                       	    	<span class="story-title">The sports world continues to be plagued by ‘The Drake Curse’</span>
	                            	<span class="story-time">  - 2 days ago</span>
	                            </a>
	                        </h3>
	                    </li>
	                	                </ul>
	            </div>
	    			    	</div><!-- .story -->
	    </div><!-- .breaking-banner -->
	    
                </div><!-- END .large-12 .columns -->

            </div><!-- END .row -->

        </div><!-- END .site-navigation -->

    </header><!-- END #header -->
		<div id="main-container">
<div class="row">

        <main class="content large-9 columns sidebar-right"  role="main" itemscope itemtype="http://schema.org/Article">

            <article id="post-58654" class="post-58654 post type-post status-publish format-standard has-post-thumbnail hentry category-arts">

    
        <div class="row post-top large">

            <div class="entry-media-wrapper">

			
	            <div class="entry-content-media" style="background-image: url(https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE-667x445.jpg);">
					
						                
				<img src="https://theaggie.org/wp-content/uploads/2019/05/thedirtfeelin_ROSIE-SCHWARZ_AGGIE-667x445.jpg" alt="Tha Dirt Feelin" style="display: none;"/>
	                
	                	
	            </div>
	
	        </div><!-- END .entry-media-wrapper -->
	
	        <div class="entry-header-wrapper">

    
        	<header class="entry-header">

        		
        		
        			<h1 class="entry-title" itemprop="headline">Tha Dirt Feelin</h1><!-- END .entry-title -->

        		
        		        <div class="entry-meta clearfix">

            
            
        <div class="author-link">
            <img alt='' src='https://secure.gravatar.com/avatar/e1a249070626d0e95ba9784b1fc38843?s=24&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/e1a249070626d0e95ba9784b1fc38843?s=48&#038;d=mm&#038;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' />            <a class="author-name author" href="https://theaggie.org/author/theaggie/" title="View all posts by Rosie Schwarz — arts@theaggie.org" rel="author">Rosie Schwarz — arts@theaggie.org</a>
        </div>

    <div class="date">8 hours ago</div>
        </div><!-- END .entry-meta -->
    
        	</header><!-- END .entry-header -->

    
        </div><!-- END .large-6.columns -->

    </div><!-- END .row -->

    
        
            <p style="font-size: 12px; color: #aaaaaa;">Photo Credits: ROSIE SCHWARZ / AGGIE</p>
    	<div class="entry-content">

		
    <div id="post-side-share-above" class="post-side-share position-above">
                <div class="clearfix">
            <a class="icon icon-twitter icon_embed_tw" href="http://twitter.com/home/?status=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F+-+Tha+Dirt+Feelin" title="Twitter" target="blank">
                <span class="share-network">Twitter</span>
            </a>
            <a class="icon icon-facebook icon_embed_fb" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F&amp;t=Tha+Dirt+Feelin" title="Facebook" target="blank">
                <span class="share-network">Facebook</span>
            </a>

            <a class="icon icon-google-plus icon_embed_gplus" href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F" title="Googleplus" target="blank">
                <span class="share-network">Google +</span>
            </a>

            <a class="icon icon-linkedin icon_embed_linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A%2F%2Ftheaggie.org%2F2019%2F05%2F30%2Ftha-dirt-feelin%2F&amp;summary=Tha+Dirt+Feelin&amp;source=https%3A%2F%2Ftheaggie.org" title="Linkin" target="blank">
                <span class="share-network">Linkedin</span>
            </a>

            <a class="icon icon-comment icon_embed_comments" href="#comment" title="Comments">
                <span class="share-network">Comments</span>
            </a>

            
            <span class="arrow"></span>
        </div>
    </div>
    
		<div itemprop="articleBody" class="clearfix">
			
<p class="has-medium-font-size"><strong>A local Davis band returns to Central Park with new energy</strong></p>



<p>During Spring Quarter, students and Davis residents attend the Wednesday Farmer’s Market to enjoy fresh produce, food booths, Central Park and the different musical acts that play. The bands bring a similar energy of relaxing covers and family friendly music that are great to dance to or enjoy as background music to your conversation. Recently, however, local band Tha Dirt Feelin returned to the Farmer’s Market after a long hiatus and brought a newfound energy to the beautiful night atmosphere.</p>



<p>	Tha Dirt Feelin is a local band, described by the <a href="https://www.davisenterprise.com/arts/tha-dirt-feelin-to-bring-funk-and-soul-to-picnic-in-the-park/">Davis Enterprise</a> as “the local kings of funk and soul, with a style that lies somewhere between Parliament Funkadelic and early Red Hot Chili Peppers.” However, beyond the band’s extremely catchy and relatable songs is the contagious energy that both their music and band members bring to the stage. The band’s lead singer Marque Cass will often take a moment to let his band jam without him as he dances, goes off stage and chats with his fans.</p>



<p>	Looking around, many people dancing near the stage can be seen sporting tie-dye “Tha Dirt Feelin” shirts. It’s apparent that, unlike many of the other bands which sometimes serve as more ambient music, Tha Dirt Feelin has an extensive fan base. While some of the songs that Tha Dirt Feelin perform are covers and mashups, their unique style and energy provide the perfect mixture of familiarity and originality. Those dancing are able to sing the words to the songs but can easily adapt to the creative changes Tha Dirt Feelin adds.</p>



<p>	Beyond the band’s energy, it’s apparent that Tha Dirt Feelin has spent years getting to know the Davis community. The band explains they <a href="https://thadf.com/">met</a> “by chance at school in Davis, California almost eight years ago. The music came from random jam sessions and turned into shows at Harlows and Torch Club in Sacramento, Sauced in Livermore, Davis Farmer’s Market and large stages like Whole Earth Festival and more.”</p>



<p>	For those who have missed Tha Dirt Feelin’s latest performance, they actively post on Facebook and Instagram about their whereabouts. They are constantly engaging with their fans and making new music. Keep an eye out for this incredibly energetic and unique band; they are guaranteed to make your day.<br><strong>Written By: Rosie Schwarz — </strong><a><strong>arts@theaggie.org</strong></a></p>
		</div>

		
	</div><!-- END .entry-content -->
	
</article><!-- END #post-58654 -->

        <footer class="meta clearfix">
                    </footer><!-- END .entry-meta -->

    
		<div id="related-posts" class="clearfix">

			<h3><span>Some Related Posts</span></h3>

			<ul class="clearfix five-items">

			
				<li class="has-thumb ">

					<a href="https://theaggie.org/2019/05/29/cooking-with-wine/" class="inner">

						<div class="entry-content-media">
							<div class="post-thumb preload image-loading">
	                        									<img src="https://theaggie.org/wp-content/uploads/2019/05/LRG_DSC05289-e1558316445676-300x302.jpg" alt="Cooking with Wine" width="300" height="302"/>
	                       			                       	</div>
	                    </div>

						<header class="entry-header">
							        <div class="entry-meta clearfix">
                                            </div><!-- END .entry-meta -->
    							<h4 class="entry-title">Cooking with Wine</h4>
							        <div class="entry-excerpt">Chicken Provençal Returning home after a long Monday, I promptly marched t</div><!-- END .entry-excerpt -->
    	 					</header><!-- .entry-summary -->

					</a>

				</li><!--column-->

	  			
			
				<li class="has-thumb ">

					<a href="https://theaggie.org/2019/05/28/cclass-hosts-patio-de-colores/" class="inner">

						<div class="entry-content-media">
							<div class="post-thumb preload image-loading">
	                        									<img src="https://theaggie.org/wp-content/uploads/2019/05/patio_ar_ROXANDA-REYES_COURTESY-299x150.jpg" alt="CCLASS hosts Patio De Colores" width="299" height="150"/>
	                       			                       	</div>
	                    </div>

						<header class="entry-header">
							        <div class="entry-meta clearfix">
                                            </div><!-- END .entry-meta -->
    							<h4 class="entry-title">CCLASS hosts Patio De Colores</h4>
							        <div class="entry-excerpt">The colorful event has come to an end The Center for Chicanx and Latinx Aca</div><!-- END .entry-excerpt -->
    	 					</header><!-- .entry-summary -->

					</a>

				</li><!--column-->

	  			
			
				<li class="has-thumb ">

					<a href="https://theaggie.org/2019/05/28/grand-opening-burger-patch/" class="inner">

						<div class="entry-content-media">
							<div class="post-thumb preload image-loading">
	                        									<img src="https://theaggie.org/wp-content/uploads/2019/05/burgerpatch_ar_DANEA-HORN_COURTESY-299x150.jpeg" alt="Grand Opening: Burger Patch" width="299" height="150"/>
	                       			                       	</div>
	                    </div>

						<header class="entry-header">
							        <div class="entry-meta clearfix">
                                            </div><!-- END .entry-meta -->
    							<h4 class="entry-title">Grand Opening: Burger Patch</h4>
							        <div class="entry-excerpt">“Convenient Consciousness” with plant-based fast food Sacramento’s ne</div><!-- END .entry-excerpt -->
    	 					</header><!-- .entry-summary -->

					</a>

				</li><!--column-->

	  			
			
				<li class="has-thumb ">

					<a href="https://theaggie.org/2019/05/27/commentary-the-childrens-books-that-define-us/" class="inner">

						<div class="entry-content-media">
							<div class="post-thumb preload image-loading">
	                        									<img src="https://theaggie.org/wp-content/uploads/2019/05/childrensbooks_ar_ALLYSON-KO_AGGIE-299x150.jpg" alt="Commentary: The Children’s Books that Define Us" width="299" height="150"/>
	                       			                       	</div>
	                    </div>

						<header class="entry-header">
							        <div class="entry-meta clearfix">
                                            </div><!-- END .entry-meta -->
    							<h4 class="entry-title">Commentary: The Children’s Books that Define Us</h4>
							        <div class="entry-excerpt">Children books that have had a lasting effect on students After taking ENL </div><!-- END .entry-excerpt -->
    	 					</header><!-- .entry-summary -->

					</a>

				</li><!--column-->

	  			
			
				<li class="has-thumb ">

					<a href="https://theaggie.org/2019/05/27/the-entanglement-of-jazz-and-hip-hop/" class="inner">

						<div class="entry-content-media">
							<div class="post-thumb preload image-loading">
	                        									<img src="https://theaggie.org/wp-content/uploads/2019/05/rapandjazz_ar_KATHERINE_FRANKS-299x150.png" alt="The Entanglement of Jazz and Hip-Hop" width="299" height="150"/>
	                       			                       	</div>
	                    </div>

						<header class="entry-header">
							        <div class="entry-meta clearfix">
                                            </div><!-- END .entry-meta -->
    							<h4 class="entry-title">The Entanglement of Jazz and Hip-Hop</h4>
							        <div class="entry-excerpt">A Musical Love Affair Jazz, characterized by free improvisation and syncopa</div><!-- END .entry-excerpt -->
    	 					</header><!-- .entry-summary -->

					</a>

				</li><!--column-->

	  			
			
		  </ul>

	   </div><!--related-->

	
<div id="comments" class="no-comments" itemscope itemtype="http://schema.org/UserComments">

	
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span class="comment-header">Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/05/30/tha-dirt-feelin/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://theaggie.org/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<textarea id="comment" name="comment" cols="45" rows="8" aria-describedby="form-allowed-tags" aria-required="true" required="required"></textarea>
			<div class="comment-form-author clearfix">
			<input id="author" name="author" type="text" value="" size="30" aria-required='true' required='required' />
			<h6><label for="author">Name<span class="required">*</span></label></h6>
			</div>

			<div class="comment-form-email clearfix">
			<input id="email" name="email" type="text" value="" size="30" aria-required='true' required='required' />
			<h6><label for="email">Email<span class="required">*</span></label></h6>
			</div>

			<div class="comment-form-url clearfix">
			<input id="url" name="url" type="text" value="" size="30" />
			<h6><label for="url">Website</label></h6>
			</div>


<div class="si_captcha_small"><img id="si_image_com" src="https://theaggie.org/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix=AN5U0JsvKH04zOsP" width="132" height="45" alt="CAPTCHA" title="CAPTCHA" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="AN5U0JsvKH04zOsP" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','https://theaggie.org/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix='); return false;">
      <img class="si_captcha_refresh" src="https://theaggie.org/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh" onclick="this.blur();" /></a>
  </div>
  </div>

<p id="si_captcha_code_p">
<input id="si_captcha_code" name="si_captcha_code" type="text" />
<label for="si_captcha_code" >CAPTCHA Code</label><span class="required">*</span>
</p>

<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='58654' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	

	
</div><!-- END #comments-respond -->            <meta itemprop="datePublished" content="2019-05-30T15:35:15-08:00"/>
            <meta itemprop="dateModified" content="2019-05-30T15:35:17-08:00"/>

            <meta itemprop="image" content=""/>
        </main><!-- END -->

        
            <aside class="large-3 columns sidebar-right sidebar-wrapper" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">

                <div class="sidebar">

                     
<div class="widget widget_text clearfix">			<div class="textwidget"><div style="text-align:center;margin-top:15px;">
    <div style="margin-bottom: 10px;">
        <a target="_blank" rel="nofollow" title="Subscribe to our e-newsletter" href="http://theaggie.us9.list-manage.com/subscribe?u=5055b3679fe5f449e39859a2c&id=94a345f90a">
            <img alt="newsletter" title="Subscribe to our e-newsletter" width="230" height="76" style="display:inline;width:230px;height:76px;margin:0;border:none;" src="https://theaggie.org/wp-content/uploads/TheAggie_SubscribeButton.png">
        </a>
    </div>
    <div>
        <a target="_blank" rel="nofollow" title="Follow us on Facebook" href="https://www.facebook.com/CaliforniaAggie">
            <img alt="Facebook" title="Follow us on Facebook" width="48" height="48" style="display:inline;width:48px;height:48px;margin:0;margin-right:10px;border:none;" src="https://theaggie.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/facebook.png">
        </a>
        <a target="_blank" rel="nofollow" title="Follow us on Twitter" href="https://twitter.com/californiaaggie">
            <img alt="twitter" title="Follow us on Twitter" width="48" height="48" style="display:inline;width:48px;height:48px;margin:0;margin-right:10px;border:none;" src="https://theaggie.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/twitter.png">
        </a>
        <a target="_blank" rel="nofollow" title="Check out our instagram feed" href="https://instagram.com/thecaliforniaaggie/">
            <img alt="instagram" title="Check out our instagram feed" width="48" height="48" style="display:inline;width:48px;height:48px;margin:0;border:none;" src="https://theaggie.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/96x96/instagram.png">
        </a>
    </div>
</div></div>
		</div><div class="widget aggieads_widget clearfix"></div><div class="widget aggieads_widget clearfix"></div><div class="widget aggieads_widget clearfix">    <div class="aggieads-sidebar">
        <a href="https://theaggie.org?aggieads_counter=aHR0cHM6Ly93d3cubW9uZGF2aWFydHMub3JnL2V2ZW50LzIwMTgtMTkvaW5kaWdvLWdpcmxz" target="_blank">
            <img src="https://theaggie.org/wp-content/uploads/2019/05/MC.300x250.Indigo.JUN_.jpg" alt>
        </a>
    </div></div><div class="widget aggieads_widget clearfix"></div><div class="widget aggieads_widget clearfix">    <div class="aggieads-footer" id="aggieads-footer">
        <div class="wrapper">
            <b class="close" onclick="document.getElementById('aggieads-footer').remove()">×</b>
            <a href="https://theaggie.org?aggieads_counter=aHR0cDovL2xvdmVsYXVuZHJ5LmNvbS9sb2NhdGlvbnMvZGF2aXM-" target="_blank">
                <img src="https://theaggie.org/wp-content/uploads/2017/12/lovelaundry-5.gif" alt>
            </a>
        </div>
    </div></div>

                </div><!-- END .sidebar -->

            </aside><!-- END -->

        
    </div><!-- END .row -->


</div><!-- #main-container -->
    <div id="global-loading" class="loading-dots">
        <span class="dot-1"></span>
        <span class="dot-2"></span>
        <span class="dot-3"></span>
    </div>
    <div id="global-alert" class="alert alert-message"></div>
<footer id="bottom-footer" class="bottom-footer" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div id="gototop"><a href="#theme-wrapper" rel="nofollow">Back to top</a></div><div id="colophon" class="creds" role="contentinfo"><div id="theme-credits">© 2017, ASUCD. Designed by <a href="http://creativemedia.ucdavis.edu">Creative Media<a></div></div></footer></div><!-- #theme-wrapper-inner -->
</div><!-- #theme-wrapper -->
<script></script><script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-html5-media/assets/js/jplayer.js?ver=1.0'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/accordion.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/mouse.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/jquery/ui/slider.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var radium_framework_globals = {"page_bg_images":null,"js_dir":"https:\/\/theaggie.org\/wp-content\/themes\/newscore\/assets\/js","ajaxurl":"https:\/\/theaggie.org\/wp-admin\/admin-ajax.php","sticky_header":"true","space_menu_evenly":"true","back_to_top":"true","share_posts_js":"false","theme_url":"https:\/\/theaggie.org\/wp-content\/themes\/newscore","ajax_error_message":"Sorry, unable to load more posts. Please try again.","ajax_error_message2":"Sorry, unable to load this post using ajax. Redirecting...","cart_added_message":"has been added to the shopping cart."};
/* ]]> */
</script>
<script type='text/javascript' src='https://theaggie.org/wp-content/themes/newscore/assets/js/plugins.min.js?ver=1.9.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/themes/newscore/assets/js/main.min.js?ver=1.9.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/comment-reply.min.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/themes/newscore/assets/js/jquery.validate.min.js?ver=1.9.4'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/prettyphoto/js/jquery.prettyPhoto.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/galleria/galleria.min.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/radium-galleries-lite/assets/frontend/galleria/themes/classic/galleria.classic.min.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-includes/js/wp-embed.min.js?ver=6ae6196510fd9cd4974b742acb52f190'></script>
<script type='text/javascript' src='https://theaggie.org/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<!-- KCCounter --><script>(function($){var kcckey = 'kcccount',pidkey = 'kccpid',urlpatt = 'https://theaggie.org?download={download}&kcccount={url}',onclickEvents = 'click contextmenu mousedown',kccclick__fn = function(e){this.href = e.data.kccurl;},q_symbol_to_alts__fn = function(url){return url.replace(/[?]/g, '__QUESTION__').replace(/[&]/g, '__AMPERSAND__');};$('a.').each(function(){var $a = $(this),href = $a.attr('href'),pid = $a.data( pidkey ),kccurl;if( href.indexOf(kcckey) !== -1 ) return;kccurl = urlpatt.replace('{in_post}', (pid ? pid : '') );kccurl = kccurl.replace('{download}', ( !! $a.data('kccdownload') ? 1 : '') );kccurl = kccurl.replace('{url}', q_symbol_to_alts__fn( href ) );$a.attr('data-kcc', 1).on( onclickEvents, { kccurl: kccurl }, kccclick__fn );});$('a[href*="'+ kcckey +'"]').each(function(){var $a = $(this),href = $a.attr('href'),re = new RegExp( kcckey +'=(.*)' ),url;if( url = href.match(re)[1] ){if( !! parseInt(url) )url = '/#download'+ url;$a.attr('data-kcc', 1).attr('href', url ).on(onclickEvents, { kccurl: href.replace( url, q_symbol_to_alts__fn(url) ) }, kccclick__fn );}});})(jQuery);</script>
</body>
</html>
<!-- Dynamic page generated in 0.402 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2019-05-30 23:17:29 -->

<!-- Compression = gzip -->